Product versions and support expiration

Each of the new versions of the Macrobond application can be installed directly via the Macrobond platform by clicking the yellow line which appears on the screen or by selecting Check for update on the Help menu. If you need assistance, a description of how to upgrade may be found here. You might need additional help from your IT-department.

You are always welcome to contact the Macrobond team to arrange access or if you have any questions.

  • Version 1.21 released April 2019, support ends on the 1st of January 2022
  • Version 1.20 released November 2018, support ends on the 1st of January 2021
  • Version 1.19 released May 2018, support ends on the 1st of January 2021
  • Version 1.18 released October 2017, support ends on the 1st of January 2020
  • Version 1.17 released March 2017, support ends on the 1st of January 2020
  • Version 1.16 released July 2016, support ended on the 1st of January 2019
  • Version 1.15 released September 2015, support ended on the 1st January 2018
  • Version 1.14 released December 2014, support ended on the 1st January 2018
  • Version 1.13 released June 2014, support ended on the 1st January 2018
  • Version 1.12 released December 2013, support ended on the 1st January 2017
  • Version 1.11 released October 2013, support ended on the 1st January 2017
  • Version 1.10 released June 2013, support ended on the 1st January 2017
  • Version 1.9 released March 2013, support ended on the 1st January 2017
  • Version 1.8 released October 2012, support ended on the 1st January 2016
  • Version 1.7 released June 2012, support ended on the 1st January 2016
  • Version 1.6 released May 2012, support ended on the 1st January 2016
  • Version 1.5 released March 2012, support ended on the 1st January 2016
  • Version 1.4 released October 2011, support ended on the 1st January 2015
  • Version 1.3 released June 2011, support ended on the 1st January 2015
  • Version 1.2 released April 2011, support ended on the 1st January 2015
  • Version 1.1 released September 2010, no longer supported
  • Version 1.0 released May 2010, no longer supported