With the Analytics Activity you create documents where you can define calculations and presentations of data.

AnalyticsActivity-1.1

The Analysis tree

When you do calculations, the Analysis tree is the central part of an Analytics document. There are a number of Analyses that you can use as building blocks in a sequence of calculations. Typically, the last building block is a presentation such as a Time chart or a Table.

When you create a new empty Analytics document, there will already be two building blocks in the Analysis tree: a Series list followed by a Time chart.

You can insert new analyses to the sequence in the analysis tree. This is done by selecting the analysis that should follow the new analysis; select an analysis in the drop down list to the left of the Insert button and finally press Insert.

In the image above, there are three building blocks: Series list, Rate of change and Time chart. The series listed in the Series list will be processed by the Rate of change analysis and finally presented in the Time chart. Click on an analysis in the tree in order to see the settings where you can make changes.

To delete an analysis from the tree, select the analysis and then press Delete. (Either “Del” on the keyboard, Delete in the Edit menu or the X in the toolbar.)

Undo

You can always undo your last action within an Analytics document. (Either select Undo on the Edit menu or press Ctrl+Z.)

The Series list

The Series list is always present in the Analysis tree and is the base for all calculations. It is this list of series expressions that are propagated to the subsequent analyses in the document.

AnalyticsActivity - 2

In the Series list, all series are converted to the same frequency and calendar. You can optionally select to convert all series expressed as money to the same currency.

You can add series to the Series list in different ways:

In the Series list you can not only type in series names, but you can also type in formulas containing +, -, *, /, parenthesis and a number of functions. For instance, you may type an expression like this:
sek/nok
This will calculate the exchange rate between the Swedish and Norwegian Krona.

Pressing the button Fx next to each expression will bring up a formula editor that helps you writing formulas.

There is a large set of built in formula functions and you can also define your own functions. There is much more information about the formula language in the document “Macrobond formula language” on the Getting started page.

On the tab Conversions settings, you can change setting for frequency and missing value conversions.

The tab Forecasts allows you to define your own forecasts on series. These forecasts will then be included in any calculations and presented in charts and tables.

The Time chart

A time chart can display graphs of time series as lines or columns. The horizontal axis always represents time and the vertical axes represent the value of the time series at that time.

AnalyticsActivity - 3

When you click on a part of a chart, it will be selected. The tab “Presentation properties” in the Command bar shows the properties of the selected part and allows you to make changes.

If you press the Esc key, the Chart background will be selected.

Axis

You can mark with the mouse on the time axis to zoom in on a range. If you want a more precise range, you can type in the start and end dates on the properties tab for the axis. By double clicking, you zoom all the way out.

There are two values axes: the Main scale and the Alternate scale. For each graph you can select which scale it should use. The Main scale axis controls the grid lines and is always available. The axis for the Alternate scale is only displayed if there are any graphs that use it. The Main scale is typically drawn on the right hand side and the Alternate scale on the left, but the property “Main scale to the right” available for the axes allows you to change this.

Graphs

If you select a graph, you actually select a specific point of a graph. You can get information about the value of the selected point by holding the mouse pointer over it. You can move the graph selection point by using the arrow keys.

AnalyticsActivity - 4

Another way to view the values of the graphs is to use the Ruler. You turn the ruler on and off with the Ruler command in the Chart menu or the icon in the toolbar.

AnalyticsActivity - 5

To change the legend text associated with a graph, select the graph, change to Custom mode for the content in the property bar and then change the text.

AnalyticsActivity - 6

On the Chart menu, you find the Graph layout dialog where you can select the graph type for each time series. You may also select that some time series should not be drawn as graphs at all. The order between the graphs can also be changed which is a way to control which graphs are to be drawn on the top of others.

AnalyticsActivity - 7
Legend

The legend has properties such as the background color. However, if you want to change the text of a graph entry in the legend, you can do this by selecting a graph as described on page 12.

The option “Show legend” is available both as a property for the legend and as a property for the chart background.

Chart annotations

You can add ornaments such as text boxes, lines and arrows to a chart. You may also draw ink on top of a chart by using the ink tools. All annotation tools are available in the “Chart annotations” tab in the Command bar.

AnalyticsActivity - 8

To add an annotation, select the tool and then draw on the chart by pressing down the left mouse key.

Tip: The ornament tools will be released when you have drawn an ornament and you will see the Presentation properties for the ornament. If you want to draw many lines or arrows, you can keep the Ctrl key down when drawing in the chart in order to prevent the tool from being released.

Copy chart

When the chart is selected, or any part in the chart, you can copy the whole chart to the clipboard. (Either selected Copy on the Edit menu, the copy button in the toolbar, the shortcut Ctrl+C or Copy from the context menu of the chart.)

The chart will be copied as a picture that you can paste into other applications. On the clipboard there will also be a Macrobond chart object. In applications that support objects, such as Microsoft Office, you will not only get a picture of the chart when you paste the object, but you will also get the ability to update the chart if you have the Macrobond application installed. You can either just refresh the chart with the latest data or you can edit the chart.

The commands for refresh and edit can be found on the context menu that is displayed when you click with the right mouse button on the Macrobond chart in the Office application. There is also a special Macrobond menu in Office where you will find a Refresh command that refreshes all charts in the Office document.

Creating Analytics documents from Browse presentations

A common scenario is that you want to make changes to a chart that you have found in the Browse Activity. You can then open a copy of the chart in the Analytics Activity. You do this with the “Open in Analytics” command that you find on the File menu and in the toolbar.

AnalyticsActivity - 9

Once you have a copy of the document in Analytics, you can make changes to the chart, analyses and the set of series.